Thread (9 messages) 9 messages, 4 authors, 2015-06-01

Re: [PATCH v4 3/17] video: fbdev: gbefb: use arch_phys_wc_add() and devm_ioremap_wc()

From: Ingo Molnar <mingo@kernel.org>
Date: 2015-05-29 06:41:56
Also in: lkml

* Luis R. Rodriguez [off-list ref] wrote:
+		gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
+					  gbe_mem_size);
+		gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
+						 &gbe_dma_addr, GFP_KERNEL);
+	par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);
+	arch_phys_wc_del(par->wc_cookie);
+	arch_phys_wc_del(par->wc_cookie);
Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is 
coherent across the various APIs?

Thanks,

	Ingo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help