Thread (27 messages) flat view 27 messages, 2 authors, 2012-12-19

Re: [PATCH 2/7] OMAPDSS: DISPC: Move DISPC specific dss_reg_fields to dispc_features

From: Tomi Valkeinen <hidden>
Date: 2012-11-30 10:25:35
Also in: linux-omap

On 2012-11-30 12:02, Chandrabhanu Mahapatra wrote:
On Thursday 29 November 2012 05:35 PM, Tomi Valkeinen wrote:
quoted
quoted
diff --git a/drivers/video/omap2/dss/dss.h b/drivers/video/omap2/dss/dss.h
index 84a7f6a..aa273d8 100644
--- a/drivers/video/omap2/dss/dss.h
+++ b/drivers/video/omap2/dss/dss.h
@@ -143,6 +143,10 @@ struct reg_field {
 	u8 low;
 };
 
+struct register_field {
+	u8 start, end;
+};
+
We already have the dss_reg_field struct. I think it's better to move
that to dss.h, and use it, instead of creating an exact duplicate.

 Tomi
register_field appears to be a more generic a name rather than
dss_reg_field. Also I was thinking to initialise
Yes, register_field is a more generic name, and that's one reason I
don't suggest using it. There's a possibility of name clash if some
common linux framework would use a similar name. So dss_reg_field refers
to a register field, used by (omap)dss.

It could also be renamed to omapdss_reg_field, but that's a bit longer.
But perhaps naming it omapdss_reg_field would separate it better from
dss_reg_fields.

 Tomi

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help