On Thu, Oct 04, 2012 at 07:59:19PM +0200, Steffen Trumtrar wrote:
[...]
quoted hunk ↗ jump to hunk
diff --git a/include/linux/of_display_timings.h b/include/linux/of_display_timings.h
[...]
+struct display_timings {
+ unsigned int num_timings;
+ unsigned int default_timing;
+
+ struct signal_timing **timings;
+};
+
+struct timing_entry {
+ u32 min;
+ u32 typ;
+ u32 max;
+};
+
+struct signal_timing {
I'm slightly confused by the naming here. signal_timing seems overly
generic in this context. Is there any reason why this isn't called
display_timing or even display_mode?