On Mon, Mar 14, 2005 at 02:25:48PM +0100, Geert Uytterhoeven wrote:
On Mon, 14 Mar 2005, Paul Mundt wrote:
quoted
While the pci_resource_xxx() routines would still technically do the
right thing, this is purely coincidental.
Nah, they would work better here, since they do include the +1 ;-)
Indeed. However, using the pci_ prefixing here is a misnomer. It may be
worth having more generic struct resource accessors that take care of
this sort of thing, as clearly this is a common issue (perhaps
resource_start()/resource_len() or something equally silly).