Thread (8 messages) flat view 8 messages, 3 authors, 2016-09-15

Re: fscrypto: rename completion callbacks to reflect usage

From: Theodore Ts'o <tytso@mit.edu>
Date: 2016-09-15 20:56:21
Also in: linux-f2fs-devel, linux-fsdevel

On Wed, Sep 14, 2016 at 01:57:14PM -0700, Eric Biggers wrote:
fscrypt_complete() was used only for data pages, not for all
encryption/decryption.  Rename it to page_crypt_complete().

dir_crypt_complete() was used for filename encryption/decryption for
both directory entries and symbolic links.  Rename it to
fname_crypt_complete().

Signed-off-by: Eric Biggers <redacted>
Thanks, applied.

						- Ted
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help