Thread (22 messages) 22 messages, 3 authors, 2014-12-12

Re: [PATCH 04/11] quota: Split ->set_xstate callback into two

From: Jan Kara <jack@suse.cz>
Date: 2014-11-18 16:05:09
Also in: linux-fsdevel, linux-xfs

On Thu 13-11-14 09:34:16, Christoph Hellwig wrote:
On Tue, Nov 11, 2014 at 10:04:18PM +0100, Jan Kara wrote:
quoted
Split ->set_xstate callback into two callbacks - one for turning quotas
on (->sysquota_on) and one for turning quotas off (->sysquota_off). That
way we don't have to pass quotactl command into the callback which seems
cleaner.
Yes, I much prefer these to be split.  But the names seem a little odd,
why not enable_quota/disable_quota?
  I wanted to clearly separate this from quota_on() / quota_off() callbacks
which are for userspace visible quota files. However enable_quota /
disable_quota sound fine as well.
 
quoted
+static unsigned int generic_to_xfs_flags(unsigned int uflags)
xfs_quota_flags() ?
  OK.

								Honza
  
 
-- 
Jan Kara [off-list ref]
SUSE Labs, CR

_______________________________________________
xfs mailing list
xfs@oss.sgi.com
http://oss.sgi.com/mailman/listinfo/xfs
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help