Re: [PATCH 12/12] riscv: dts: ultrarisc: Add Milk-V Titan board device tree
flat view
From: sashiko-bot@kernel.org
Date: 2026-08-25 06:16:16
Also in:
dmaengine
Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider: - [Medium] The comment explaining the `phy-mode = "rgmii"` configuration contradicts how the Realtek RTL8211F PHY driver actually behaves. - [Low] The Ethernet PHY node is named `phy@0` instead of the standard `ethernet-phy@0`. --
--- Patch [12]: [PATCH 12/12] riscv: dts: ultrarisc: Add Milk-V Titan board device tree ---commit 3f673472054f18222d34b30ffbabd903e6df950c Author: Jia Wang [off-list ref] riscv: dts: ultrarisc: Add Milk-V Titan board device tree This commit adds the device tree for the Milk-V Titan, an ITX motherboard based on the UltraRISC DP1000 SoC. Link: https://milkv.io/docs/titan/overview
quoted hunk ↗ jump to hunk
diff --git a/arch/riscv/boot/dts/ultrarisc/dp1000-milkv-titan.dts b/arch/riscv/boot/dts/ultrarisc/dp1000-milkv-titan.dts new file mode 100644 index 0000000000000..f1a0efee3d746 --- /dev/null +++ b/arch/riscv/boot/dts/ultrarisc/dp1000-milkv-titan.dts
[ ... ]
quoted hunk ↗ jump to hunk
+ðernet { + phy-handle = <&phy0>; + /* + * RTL8211F: board timing uses PHY strap delays; keep plain "rgmii". + * Enabling PHY internal delays via "rgmii-id" breaks Ethernet traffic. + */ + phy-mode = "rgmii";
[Severity: Medium] Does this comment accurately describe how the Realtek RTL8211F PHY driver handles "rgmii"? Looking at rtl8211f_config_rgmii_delay() in drivers/net/phy/realtek/realtek_main.c, configuring an RTL8211F PHY with phy-mode = "rgmii" causes the driver to explicitly zero out the internal TX and RX delay registers, overriding and disabling any hardware strap delays. If the board functions correctly with "rgmii", it actually requires the PHY delays to be disabled. Could the comment be updated to prevent confusion about the hardware configuration?
quoted hunk ↗ jump to hunk
+ + status = "okay"; + + mdio { + compatible = "snps,dwmac-mdio"; + #address-cells = <1>; + #size-cells = <0>; + + phy0: phy@0 { + reg = <0>;
[Severity: Low] Does this node name correctly follow the devicetree bindings for ethernet PHYs? The node name phy@0 does not match the regex pattern required by the Ethernet PHY DT binding (Documentation/devicetree/bindings/net/ethernet-phy.yaml). The standard name is ethernet-phy@0. Because the name does not match the expected pattern, the schema validation is bypassed for this node and its subnodes when running make dtbs_check.
+
+ leds {-- Sashiko AI review · https://sashiko.dev/#/patchset/20260824-ultrarisc-dts-v1-0-61ab7aebe9e5@ultrarisc.com?part=12