Re: [PATCH 28/38] arm64: dts: mediatek: mt8173: Fix pinctrl node names and cleanup
From: Chen-Yu Tsai <wenst@chromium.org>
Date: 2025-07-24 09:49:09
Also in:
dri-devel, linux-crypto, linux-gpio, linux-media, linux-mediatek, linux-phy, linux-remoteproc, linux-sound, lkml
On Thu, Jul 24, 2025 at 4:40 PM AngeloGioacchino Del Regno [off-list ref] wrote:
quoted hunk ↗ jump to hunk
Fix the pinctrl node names to adhere to the bindings, as the main pin node is supposed to be named like "uart0-pins" and the pinmux node named like "pins-bus". While at it, also cleanup all of the MTK_DRIVE_(x)mA by changing that to just the (x) number. Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com> --- .../boot/dts/mediatek/mt8173-elm-hana.dtsi | 34 ++--- arch/arm64/boot/dts/mediatek/mt8173-elm.dtsi | 138 +++++++++--------- arch/arm64/boot/dts/mediatek/mt8173-evb.dts | 60 ++++---- arch/arm64/boot/dts/mediatek/mt8173.dtsi | 28 ++-- 4 files changed, 128 insertions(+), 132 deletions(-)diff --git a/arch/arm64/boot/dts/mediatek/mt8173-elm-hana.dtsi b/arch/arm64/boot/dts/mediatek/mt8173-elm-hana.dtsi index dfc5c2f0ddef..1004eb8ea52c 100644 --- a/arch/arm64/boot/dts/mediatek/mt8173-elm-hana.dtsi +++ b/arch/arm64/boot/dts/mediatek/mt8173-elm-hana.dtsi@@ -5,6 +5,14 @@ #include "mt8173-elm.dtsi" +&hdmi_mux_pins { + pins-mux { + pinmux = <MT8173_PIN_98_URTS1__FUNC_GPIO98>; + bias-pull-up; + output-high; + }; +}; +
Should probably mention that a duplicate path reference was fixed.
quoted hunk ↗ jump to hunk
&i2c0 { clock-frequency = <200000>; };@@ -67,26 +75,16 @@ trackpad2: trackpad@2c { }; }; -&mmc1 { - wp-gpios = <&pio 42 GPIO_ACTIVE_HIGH>; -}; - -&pio { - hdmi_mux_pins: hdmi_mux_pins { - pins2 { - pinmux = <MT8173_PIN_98_URTS1__FUNC_GPIO98>; - bias-pull-up; - output-high; - }; +&mmc1_pins_default { + pins-wp { + pinmux = <MT8173_PIN_42_DSI_TE__FUNC_GPIO42>; + input-enable; + bias-pull-up; }; +}; - mmc1_pins_default: mmc1default { - pins_wp { - pinmux = <MT8173_PIN_42_DSI_TE__FUNC_GPIO42>; - input-enable; - bias-pull-up; - }; - }; +&mmc1 { + wp-gpios = <&pio 42 GPIO_ACTIVE_HIGH>; }; &touchscreen {diff --git a/arch/arm64/boot/dts/mediatek/mt8173-elm.dtsi b/arch/arm64/boot/dts/mediatek/mt8173-elm.dtsi index 0d995b342d46..9ec930058b92 100644 --- a/arch/arm64/boot/dts/mediatek/mt8173-elm.dtsi +++ b/arch/arm64/boot/dts/mediatek/mt8173-elm.dtsi
[...]
- bt_wake_pins: bt_wake_pins {
- pins1 {
+ bt_wake_pins: bt-pins {Nit: I think the original name is better, because IIRC this is using the RX pin as a GPIO interrupt to wake the system from suspend.
+ pins-wake {
pinmux = <MT8173_PIN_119_KPROW0__FUNC_GPIO119>;
bias-pull-up;
};
};[...]
- pins_ds {
+ pins-ds {
pinmux = <MT8173_PIN_67_MSDC0_DSL__FUNC_MSDC0_DSL>;
drive-strength = <MTK_DRIVE_10mA>;Missed one here.
bias-pull-down = <MTK_PUPD_SET_R1R0_01>;
};[...]
quoted hunk ↗ jump to hunk
diff --git a/arch/arm64/boot/dts/mediatek/mt8173-evb.dts b/arch/arm64/boot/dts/mediatek/mt8173-evb.dts index 9fffed0ef4bf..51118a4149d8 100644 --- a/arch/arm64/boot/dts/mediatek/mt8173-evb.dts +++ b/arch/arm64/boot/dts/mediatek/mt8173-evb.dts
[...]
quoted hunk ↗ jump to hunk
@@ -245,20 +245,29 @@ pins_cmd_dat { bias-pull-up = <MTK_PUPD_SET_R1R0_01>; }; - pins_clk { + pins-clk { pinmux = <MT8173_PIN_65_MSDC0_CLK__FUNC_MSDC0_CLK>; drive-strength = <2>; bias-pull-down = <MTK_PUPD_SET_R1R0_01>; }; - pins_rst { + pins-rst { pinmux = <MT8173_PIN_68_MSDC0_RST___FUNC_MSDC0_RSTB>; bias-pull-up; }; }; - mmc1_pins_uhs: mmc1 { - pins_cmd_dat { + spi_pins_a: spi0-pins { + pins-bus { + pinmux = <MT8173_PIN_69_SPI_CK__FUNC_SPI_CK_0_>, + <MT8173_PIN_70_SPI_MI__FUNC_SPI_MI_0_>, + <MT8173_PIN_71_SPI_MO__FUNC_SPI_MO_0_>, + <MT8173_PIN_72_SPI_CS__FUNC_SPI_CS_0_>; + }; + }; + + mmc1_pins_uhs: mmc1-uhs-pins {
Wrong order?
+ pins-cmd-dat {
pinmux = <MT8173_PIN_73_MSDC1_DAT0__FUNC_MSDC1_DAT0>,
<MT8173_PIN_74_MSDC1_DAT1__FUNC_MSDC1_DAT1>,
<MT8173_PIN_75_MSDC1_DAT2__FUNC_MSDC1_DAT2>,[...] Once fixed, Reviewed-by: Chen-Yu Tsai <wenst@chromium.org>