RE: [PATCH 01/16] dt-bindings: PCI: Rename Exynos PCIe binding to Samsung PCIe
From: Shradha Todi <hidden>
Date: 2023-03-03 06:24:53
Also in:
linux-arm-kernel, linux-pci, linux-samsung-soc, lkml
-----Original Message----- From: Krzysztof Kozlowski [mailto:krzysztof.kozlowski@linaro.org] Sent: 16 February 2023 16:24 To: Shradha Todi <redacted>; lpieralisi@kernel.org; kw@linux.com; robh@kernel.org; bhelgaas@google.com; krzysztof.kozlowski+dt@linaro.org; alim.akhtar@samsung.com; jingoohan1@gmail.com; Sergey.Semin@baikalelectronics.ru; lukas.bulwahn@gmail.com; hongxing.zhu@nxp.com; tglx@linutronix.de; m.szyprowski@samsung.com; jh80.chung@samsung.co; pankaj.dubey@samsung.com Cc: linux-pci@vger.kernel.org; devicetree@vger.kernel.org; linux-arm- kernel@lists.infradead.org; linux-samsung-soc@vger.kernel.org; linux- kernel@vger.kernel.org Subject: Re: [PATCH 01/16] dt-bindings: PCI: Rename Exynos PCIe binding to Samsung PCIe On 14/02/2023 13:13, Shradha Todi wrote:quoted
The current DT bindings is being used for Exynos5433 SoC only. In order to extend this binding for all SoCs manufactured by Samsung using DWC PCIe controller, renaming this file to a more generic name.Thank you for your patch. There is something to discuss/improve.quoted
Signed-off-by: Shradha Todi <redacted> --- .../pci/{samsung,exynos-pcie.yaml => samsung,pcie.yaml} | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) rename Documentation/devicetree/bindings/pci/{samsung,exynos-pcie.yaml => samsung,pcie.yaml} (93%) diff --git a/Documentation/devicetree/bindings/pci/samsung,exynos-pcie.yaml b/Documentation/devicetree/bindings/pci/samsung,pcie.yaml similarity index 93% rename from Documentation/devicetree/bindings/pci/samsung,exynos-pcie.yaml rename to Documentation/devicetree/bindings/pci/samsung,pcie.yaml index f20ed7e709f7..6cd36d9ccba0 100644--- a/Documentation/devicetree/bindings/pci/samsung,exynos-pcie.yaml +++ b/Documentation/devicetree/bindings/pci/samsung,pcie.yamlWe keep the name rather tied to compatible, not generic. There are no other compatibles here, so I don't think we should rename it.
Our intention to rename was to have a common name for Samsung manufactured SoCs having PCIe controller. Though this change may not be a blocker for us but we feel it will be good to have a common name as this file will not have bindings only for Exynos series of SoC (Samsung Sys. LSI designed) but also custom ASICs such as FSD / ARTPEC SoC (Samsung Foundry designed). We hope we are not breaking any ABI as such in this patch. Shradha
Best regards, Krzysztof