On 03/08/2022 12:46, Jagan Teki wrote:
On Wed, 3 Aug 2022 at 16:13, Krzysztof Kozlowski
[off-list ref] wrote:
quoted
On 03/08/2022 12:24, Jagan Teki wrote:
quoted
quoted
Vendor in filename is needed.
Yes this follows how similar rockchip vendor notation
$ ls include/dt-bindings/power/rk3* -l
include/dt-bindings/power/rk3036-power.h
include/dt-bindings/power/rk3066-power.h
include/dt-bindings/power/rk3128-power.h
include/dt-bindings/power/rk3188-power.h
include/dt-bindings/power/rk3228-power.h
include/dt-bindings/power/rk3288-power.h
include/dt-bindings/power/rk3328-power.h
include/dt-bindings/power/rk3366-power.h
include/dt-bindings/power/rk3368-power.h
include/dt-bindings/power/rk3399-power.h
include/dt-bindings/power/rk3568-power.h
So when are we going to switch to vendor,device pattern if you keep
adding files with wrong naming?
Do you mean the above files are following the wrong naming pattern?
Yes, or at least discouraged naming. The recommended naming which I hope
all new files will follow are vendor,device.h.
Best regards,
Krzysztof