Re: [RFC PATCH v12 4/5] PCI / PM: Add support for the PCIe WAKE# signal for OF
From: Rafael J. Wysocki <hidden>
Date: 2017-12-28 00:32:28
Also in:
linux-pci, linux-pm, lkml
From: Rafael J. Wysocki <hidden>
Date: 2017-12-28 00:32:28
Also in:
linux-pci, linux-pm, lkml
On Wed, Dec 27, 2017 at 4:30 PM, Rob Herring [off-list ref] wrote:
On Tue, Dec 26, 2017 at 7:32 PM, JeffyChen [off-list ref] wrote:quoted
Hi Rob, Thanks for your reply. On 12/27/2017 07:56 AM, Rob Herring wrote:quoted
quoted
quoted
drivers/of/of_pci_irq.c | 49 +++++++++++++++++++++++++++++++Please move this to drivers/pci/of.c (or perhaps create pci/of_irq.c).quoted
quoted
drivers/pci/Makefile | 1 + drivers/pci/pci-driver.c | 10 +++++++ drivers/pci/pci-of.c | 75 ++++++++++++++++++++++++++++++++++++++++++++++++We already have drivers/pci/of.c. It's not clear what the difference is from the filenames. Either merge with of.c or perhaps of-pm.c.this new file does something similar to the pci-acpi.c and pci-mid.c..pci-acpi.c has similar things to pci/of.c. The naming is just not consistent. Also, I plan to move the rest of drivers/of/of_pci* to drivers/pci.quoted
and i am agree the naming is not clear, maybe we can rename both of those files to something like pci-pm-***.c?At least pci-acpi.c is more than just PM functions, so that doesn't make sense. Given that all the ACPI related functions are in 1 file, we should do the same for DT.
Agreed. Thanks, Rafael -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html