Hi,
I know my response is late ...
Hi Oliver
On 07/20/2017 02:43 AM, Oliver Hartkopp wrote:
quoted
Hi Franklin,
On 07/20/2017 01:36 AM, Franklin S Cooper Jr wrote:
quoted
+#ifdef CONFIG_OF
+void of_transceiver_is_fixed(struct net_device *dev)
+{
(..)
quoted
+}
+EXPORT_SYMBOL(of_transceiver_is_fixed);
+#endif
I'm not sure about the naming here.
As this is a CAN transceiver related option it should be named accordingly:
I contest the the name too:
1) the can transceiver isn't fixed at all, it limited to the higher
bitrates.
2) of_can_transceiver_is_fixed suggests to test if a transceiver is
fixed, it does not suggest to load some properties from the device tree.
of_can_load_transceiver looks way more clear to me.
That's my opinion.
The important things, like the contents of the functions, look good.
Kind regards,
Kurt Van Dijck