Thread (35 messages) 35 messages, 6 authors, 2016-09-13

Re: [PATCH/RFC v3 02/22] soc: renesas: Add R-Car RST driver

flat view

From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Date: 2016-06-10 13:08:41
Also in: linux-arm-kernel, linux-renesas-soc

On Friday 10 Jun 2016 09:58:28 Geert Uytterhoeven wrote:
Hi Dirk,

On Thu, Jun 2, 2016 at 7:42 AM, Dirk Behme [off-list ref] wrote:
quoted
quoted
+int __init rcar_rst_read_mode_pins(u32 *mode)
Just a style issue: Is the string 'pins' in the function name still
relevant? I.e. what's about just 'rcar_rst_read_mode()'?
I feel "mode" is a too generic word for a public API.
It's used a several contexts inside the RST module (secure mode, 64-bit
addressing mode, free-running mode, step-up mode).
<bikeshedding>

If it's "pins" that bothers Dirk, how about rcar_rst_read_boot_mode() ? Or 
maybe rcar_rst_boot_mode(), given that the function caches the value, it 
doesn't read it every time.

</bikeshedding>

-- 
Regards,

Laurent Pinchart
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help