Re: [PATCH/RFC v9 06/19] DT: Add documentation for the mfd Maxim max77693
From: Jacek Anaszewski <hidden>
Date: 2014-12-10 12:41:28
Also in:
linux-leds, linux-media, lkml
On 12/10/2014 01:20 PM, Sylwester Nawrocki wrote:
Hi, On 04/12/14 17:12, Pavel Machek wrote:quoted
quoted
quoted
quoted
+- maxim,boost-mode :quoted
quoted
quoted
+ In boost mode the device can produce up to 1.2A of total current + on both outputs. The maximum current on each output is reduced + to 625mA then. If there are two child led nodes defined then boost + is enabled by default. + Possible values: + MAX77693_LED_BOOST_OFF - no boost, + MAX77693_LED_BOOST_ADAPTIVE - adaptive mode, + MAX77693_LED_BOOST_FIXED - fixed mode. +- maxim,boost-vout : Output voltage of the boost module in millivolts. +- maxim,vsys-min : Low input voltage level in millivolts. Flash is not fired + if chip estimates that system voltage could drop below this level due + to flash power consumption. + +Required properties of the LED child node: +- label : see Documentation/devicetree/bindings/leds/common.txt +- maxim,fled_id : Identifier of the fled output the led is connected to;I'm pretty sure this will be needed for about every chip that can drive multiple LEDs. Shouldn't it be documented in the generic documentation?OK.Well... "fled_id" is not exactly suitable name. On other busses, it would be "reg = <1>"?I think we need to clarify what the LED device node subnodes really mean. I thought initially they describe a physical current output of the LED controller, but it turns out the subnode corresponds to a LED attached to the LED controller. Since a LED can be connected to multiple outputs of the LED controller I think 'reg' property doesn't make sense here. Then presumably we should use a property in each subnode, telling which LED controller outputs a LED is connected to? For instance, if we assign numbers 0, 1 to FLED1, FLED2 outputs of MAX77693 and there is just one LED connected to those outputs we would have something like: max77693: led { compatible = "maxim,max77693-led"; ... led1 { maxim,fled-sources = <0 1>; ... }; }; Feel free to propose better name for the property, I guess we need to avoid "maxim,current-sources" due to ambiguity of the word "current".
For me this sounds reasonable. Moreover we will avoid the need for address-cells and size-cells properties in the parent node. Best Regards, Jacek Anaszewski