Thread (15 messages) 15 messages, 3 authors, 2015-01-13

Re: [PATCH 2/5] gpio: Cygnus: add GPIO driver

From: Ray Jui <rjui@broadcom.com>
Date: 2014-12-08 01:34:23
Also in: linux-arm-kernel, linux-gpio, lkml


On 12/5/2014 8:24 PM, Joe Perches wrote:
On Fri, 2014-12-05 at 19:41 -0800, Ray Jui wrote:
quoted
On 12/5/2014 6:34 PM, Joe Perches wrote:
quoted
On Fri, 2014-12-05 at 18:14 -0800, Ray Jui wrote:
quoted
On 12/5/2014 5:28 PM, Joe Perches wrote:
quoted
On Fri, 2014-12-05 at 16:40 -0800, Ray Jui wrote:
quoted
+			for_each_set_bit(bit, &val, 32) {
[]
quoted
Actually, by reviewing the code more deeply, I'm not sure why using
for_each_set_bit here is 'endian unsafe'.
It's not.  The 32 confused me as it was long
and sizeof(long) isn't necessarily 32.

Maybe the 32 should be a #define

Okay, to improve readability, I will change 32 to NGPIOS_PER_BANK.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help