On Mon 11 Aug 08:40 PDT 2014, Ivan T. Ivanov wrote:
quoted hunk ↗ jump to hunk
diff --git a/arch/arm/boot/dts/qcom-apq8074-dragonboard-pmics-pins.dtsi b/arch/arm/boot/dts/qcom-apq8074-dragonboard-pmics-pins.dtsi
[...]
+
+&pm8941_gpios {
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&pm8941_gpios_default>;
+
+ pm8941_gpios_default: default {
+ group-1 {
+ pins = "gpio1", "gpio2", "gpio5", "gpio29";
+ function = PMIC_GPIO_FUNC_NORMAL;
This looks really strange, I can't get myself to stop thinking that you forgot
the <> around this (I know it's a string). I don't like these defines.
+ input-enable;
+ power-source = <PM8941_GPIO_S3>;
+ qcom,pull-up-strength = <PMIC_GPIO_PULL_UP_30>;
+ };
+ group-6 { /* TUSB3_HUB-RESET */
Why not name the nodes something useful?
If you name it tusb3-hub-reset you can skip the comment.
+ pins = "gpio6";
+ function = PMIC_GPIO_FUNC_NORMAL;
+ output-high;
+ drive-push-pull;
+ power-source = <PM8941_GPIO_VPH>;
+ qcom,pull-up-strength = <PMIC_GPIO_PULL_UP_30>;
+ qcom,drive-strength = <PMIC_GPIO_STRENGTH_MED>;
+ };
Regards,
Bjorn