Thread (7 messages) 7 messages, 3 authors, 2014-03-10

Re: [PATCH 6/6] documentation: bindings: document PMIC8921/8058 RTC

From: Stephen Boyd <hidden>
Date: 2014-03-06 01:31:33
Also in: linux-arm-msm, lkml

On 03/05/14 16:00, Josh Cartwright wrote:
On Wed, Mar 05, 2014 at 12:58:55PM -0800, Stephen Boyd wrote:
quoted
On 03/05/14 11:29, Josh Cartwright wrote:
quoted
diff --git a/Documentation/devicetree/bindings/rtc/qcom,pm8xxx-rtc.txt b/Documentation/devicetree/bindings/rtc/qcom,pm8xxx-rtc.txt
new file mode 100644
index 0000000..699bd30
--- /dev/null
+++ b/Documentation/devicetree/bindings/rtc/qcom,pm8xxx-rtc.txt
@@ -0,0 +1,29 @@
+* Real-Time Clock for Qualcomm 8058/8921 PMICs
+
+Required properties:
+- compatible: should be one of the following.
+    * "qcom,pm8058-rtc"
+    * "qcom,pm8921-rtc"
+- reg: base address of the register region
+- reg-names: corresponding reg names for the regions listed in the 'reg'
+             property, must contain:
+     "rtc_base" - base of the RTC register region
optional reg-names?
quoted
+- interrupts: interrupt list for the RTC, must contain a single interrupt
+              specifier for the alarm interrupt
+- interrupt-names: corresponding interrupt names for the interrupts listed in
+                   the 'interrupts' property, must contain:
+     "alarm" - summary interrupt for PMIC peripherals
optional interrupt-names?
It isn't clear to me why these should be made optional, I hope Rob
provides some clarification in the sdhci-msm thread.
Looks like the driver isn't using either of these properties, so I'm not
sure why they're needed. Maybe they should just be removed.
quoted
quoted
+- linux,allow-set-time: indicates that the setting of RTC time is allowed by
+                        the host CPU
Is this a "linux" property? It seems like something that other OSes
would want to know about and doesn't require any explicit knowledge
about operating  system things (like keymaps for example).
Yeah, I wasn't quite sure how to name this property.  It's
Linux-specific in the sense that the underlying operation method is
"set_time", but I agree this should be named something else...

How do you feel about simply "allow-set-time"?
Sounds ok to me.

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
hosted by The Linux Foundation
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help