Thread (13 messages) 13 messages, 4 authors, 2013-10-31

Re: [PATCH V4 1/3] ARM: dts: Add pmu sysreg node to Exynos5 dtsi file

From: Guenter Roeck <linux@roeck-us.net>
Date: 2013-10-30 15:26:39
Also in: linux-samsung-soc, linux-watchdog

On Wed, Oct 30, 2013 at 12:22:09PM +0100, Tomasz Figa wrote:
On Wednesday 30 of October 2013 15:43:19 Sachin Kamat wrote:
quoted
On 30 October 2013 15:39, Leela Krishna Amudala [off-list ref] wrote:
quoted
Hi,

On Wed, Oct 30, 2013 at 3:22 PM, Sachin Kamat [off-list ref] wrote:
quoted
Hi Leela,

On 30 October 2013 15:21, Leela Krishna Amudala [off-list ref] wrote:
quoted
This patch adds pmusysreg node to Exynos5 dtsi file to handle PMU
register accesses in a centralized way using syscon driver

Signed-off-by: Leela Krishna Amudala <redacted>
---
 arch/arm/boot/dts/exynos5.dtsi |    5 +++++
 1 file changed, 5 insertions(+)
diff --git a/arch/arm/boot/dts/exynos5.dtsi b/arch/arm/boot/dts/exynos5.dtsi
index e52b038..918e732 100644
--- a/arch/arm/boot/dts/exynos5.dtsi
+++ b/arch/arm/boot/dts/exynos5.dtsi
@@ -106,4 +106,9 @@
                #size-cells = <0>;
                status = "disabled";
        };
+
+       pmu_sys_reg: pmusysreg@1004000 {
+               compatible = "syscon";
+               reg = <0x10040000 0x5000>;
+       };
 };
Had a look at this in a bit detail and found the following.
The register base address for this block on 5250 and 5420 as per the
TRM is 0x10050000.

Also, the binding document specifies the naming convention. According
to it this node
should like:

sys_reg: sysreg@10050000 {
           compatible = "samsung,exynos5-sysreg", "syscon";
           reg = <0x10050000 0x500>;
};
I know, but here my intention is not to regmap system register (0x10050000),
but instead PMU register (0x10040000), Hence created this node.
This clashes with the existing binding for this type of node. Probably
you will need to
define it differently?
PMU and System Registers are two completely separate entities. However
a generic syscon binding can be used to represent both, because they are
just collections of registers shared by multiple IPs.
I would suggest for the participants in this discussion to send Reviewed-by:
or Acked-by: feedback once you are happy with the patches. I am sure this
would help Wim tremendously when deciding if the series is ready for
integration.

Thanks,
Guenter
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help