Re: [PATCH 1/2] pinctrl: pinconf_generic: add utility functions for add map/configs
From: Laxman Dewangan <ldewangan@nvidia.com>
Date: 2013-08-08 07:09:30
Also in:
lkml
From: Laxman Dewangan <ldewangan@nvidia.com>
Date: 2013-08-08 07:09:30
Also in:
lkml
On Wednesday 07 August 2013 11:57 PM, Linus Walleij wrote:
On Fri, Jul 26, 2013 at 7:36 PM, Stephen Warren [off-list ref] wrote:quoted
On 07/26/2013 04:15 AM, Laxman Dewangan wrote:quoted
Some of pincontrol driver needs the utility function to create map list. The utility function needed for adding mux, configs etc.It is a noble goal to unify this and thank you *very* much for taking it on.
Thanks Linus, There is 3 patches of version 3 of same series, if it gets concluded/applied then I will have some more patches for removing duplicate code from individual driver.
quoted
I don't think those are the correct files for this code. Presumably there's no reason at all why a pinctrl driver that doesn't require CONFIG_GENERIC_PINCONF can't use these basic utility functions. Perhaps add a new pinctrl-utils file?Agree with Stephen, we need to put this in a separate file, such at pinctrl-dt.c or just put it into core.c.
Version 3 address all these. Thanks,, Laxman