On Fri, Jul 25, 2014 at 2:35 PM, One Thousand Gnomes
[off-list ref] wrote:
On Fri, 25 Jul 2014 11:30:48 -0700
Andy Lutomirski [off-list ref] wrote:
quoted
[new thread because this sort of combines two threads]
There is recent interest in having a way to turn generally-available
kernel features off. Maybe we should add a good one so we can stop
bikeshedding and avoid proliferating dumb interfaces.
We sort of have one. It's called capable(). Just needs extending to cover
anything else you care about, and probably all the numeric constants
replacing with textual names.
Except that it's all backwards: these are things that default to *on*,
and people might want them to turn off. capable() is totally fscked
if you want otherwise unprivileged users to carry capabilities around,
and fixing it seems to run into endless claims that the "capability"
system is carefully designed, flawless, perfect, ideal, amazing, and
shouldn't be changed, despite the fact that it's empirically damn near
useless.
Also, capabilities do the wrong thing wrt namespaces. The things I'm
talking about aren't namespaced. They're either on or off.
--Andy