Thread (11 messages) 11 messages, 6 authors, 2014-07-30

Re: General flags to turn things off (getrandom, pid lookup, etc)

From: One Thousand Gnomes <hidden>
Date: 2014-07-25 21:37:14
Also in: linux-api, lkml

On Fri, 25 Jul 2014 11:30:48 -0700
Andy Lutomirski [off-list ref] wrote:
[new thread because this sort of combines two threads]

There is recent interest in having a way to turn generally-available
kernel features off.  Maybe we should add a good one so we can stop
bikeshedding and avoid proliferating dumb interfaces.
We sort of have one. It's called capable(). Just needs extending to cover
anything else you care about, and probably all the numeric constants
replacing with textual names.

Alan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help