On 29.06.2021 00:54:14, Vincent Mailhol wrote:
This series fixes some issues on etas_es58x and add a few improvement,
mostly on the code readability (i.e. no new features nor functional
changes in this series).
Vincent Mailhol (6):
can: etas_es58x: fix three typos in author name and documentation
can: etas_es58x: use error pointer during device probing
can: etas_es58x: use devm_kzalloc() to allocate device resources
can: etas_es58x: add es58x_free_netdevs() to factorize code
can: etas_es58x: use sizeof and sizeof_field macros instead of
constant values
can: etas_es58x: rewrite the message cast in es58{1,_fd}_tx_can_msg to
increase readability
Added to linux-can-next/testing
regards,
Marc
--
Pengutronix e.K. | Marc Kleine-Budde |
Embedded Linux | https://www.pengutronix.de |
Vertretung West/Dortmund | Phone: +49-231-2826-924 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |