This series fixes some issues on etas_es58x and add a few improvement,
mostly on the code readability (i.e. no new features nor functional
changes in this series).
Vincent Mailhol (6):
can: etas_es58x: fix three typos in author name and documentation
can: etas_es58x: use error pointer during device probing
can: etas_es58x: use devm_kzalloc() to allocate device resources
can: etas_es58x: add es58x_free_netdevs() to factorize code
can: etas_es58x: use sizeof and sizeof_field macros instead of
constant values
can: etas_es58x: rewrite the message cast in es58{1,_fd}_tx_can_msg to
increase readability
drivers/net/can/usb/etas_es58x/es581_4.c | 5 +-
drivers/net/can/usb/etas_es58x/es58x_core.c | 82 ++++++++++-----------
drivers/net/can/usb/etas_es58x/es58x_core.h | 2 +-
drivers/net/can/usb/etas_es58x/es58x_fd.c | 19 +++--
4 files changed, 51 insertions(+), 57 deletions(-)
--
2.31.1