On Mon, Jul 19, 2021 at 10:22:47AM -0700, Darrick J. Wong wrote:
quoted
-static loff_t
-iomap_seek_hole_actor(struct inode *inode, loff_t start, loff_t length,
- void *data, struct iomap *iomap, struct iomap *srcmap)
+static loff_t iomap_seek_hole_iter(const struct iomap_iter *iter, loff_t *pos)
/me wonders if @pos should be named hole_pos (here and in the caller) to
make it a little easier to read...
Sure.
...because what we're really saying here is that if seek_hole_iter found
a hole (and returned zero, thereby terminating the loop before iter.len
could reach zero), we want to return the position of the hole.
Yes.
quoted
+ return size;
Not sure why we return size here...? Oh, because there's an implicit
hole at EOF, so we return i_size. Uh, does this do the right thing if
->iomap_begin returns posteof mappings? I don't see anything in
iomap_iter_advance that would stop iteration at EOF.
Nothing in ->iomap_begin checks that, iomap_seek_hole initializes
iter.len so that it stops at EOF.