Re: [PATCH 3/3] Bluetooth: Rename HCI_BREDR into HCI_PRIMARY

From
Johan Hedberg <hidden>
Date
2016-07-09 18:51:41
Reply to
Marcel Holtmann, 2016-07-05
Hi Marcel,

On Tue, Jul 05, 2016, Marcel Holtmann wrote:
The HCI_BREDR naming is confusing since it actually stands for Primary
Bluetooth Controller. Which is a term that has been used in the latest
standard. However from a legacy point of view there only really have
been Basic Rate (BR) and Enhanced Data Rate (EDR). Recent versions of
Bluetooth introduced Low Energy (LE) and made this terminology a little
bit confused since Dual Mode Controllers include BR/EDR and LE. To
simplify this the name HCI_PRIMARY stands for the Primary Controller
which can be a single mode or dual mode controller.

Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
---
 drivers/bluetooth/btmrvl_main.c |  2 +-
 drivers/bluetooth/btsdio.c      |  2 +-
 drivers/bluetooth/btusb.c       |  2 +-
 drivers/bluetooth/hci_ldisc.c   |  2 +-
 drivers/bluetooth/hci_vhci.c    |  6 +++---
 include/net/bluetooth/hci.h     |  2 +-
 net/bluetooth/hci_conn.c        |  2 +-
 net/bluetooth/hci_core.c        | 28 +++++++++++++---------------
 net/bluetooth/hci_event.c       |  2 +-
 net/bluetooth/hci_sock.c        |  2 +-
 net/bluetooth/l2cap_core.c      |  2 +-
 net/bluetooth/mgmt.c            | 16 ++++++++--------
 12 files changed, 33 insertions(+), 35 deletions(-)
All three patches have been applied to bluetooth-next. Thanks.

Johan
Thread (2 messages) 2 messages, 2 authors, 2016-07-09
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help