Thread (3 messages) 3 messages, 2 authors, 2014-02-14

Re: [PATCHv3] hog: Use HoG device name as uHID input device name

From: Johan Hedberg <hidden>
Date: 2014-02-13 09:19:02

Hi Petri,

On Wed, Jan 29, 2014, Petri Gynther wrote:
If HoG BLE device name is known, use it when creating uHID input device.
Pass adapter and device addresses to uHID as well.
Could you perhaps elaborate a bit what exactly the "uniq" and "phys"
members are in the request (possibly with a reference to the uHID
documentation). That would make it easier to verify that the content
you're adding to them makes sense.
quoted hunk ↗ jump to hunk
+	if (device_name_known(hogdev->device)) {
+		device_get_name(hogdev->device, (char *) ev.u.create.name,
+				sizeof(ev.u.create.name) - 1);
+	} else {
+		strcpy((char *) ev.u.create.name, "bluez-hog-device");
+	}
We don't use { } for single line branches, so you can drop these here.
+	ba2str(btd_adapter_get_address(device_get_adapter(hogdev->device)),
+		(char *) ev.u.create.phys);
This is getting a bit messy with the nested function calls. I'd add
separate adapter variable here to make this a bit more readable.

Also note our coding style wrt split lines: indent the continuation
lines as much as you can (with tabs) as long as it's under 80 chars.

Also, it might be good to split this up into two patches since you've
essentially got two independent improvements here. One is making sure
the name member contains something more useful and the other is adding
some content to the uniq and phys members.

Johan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help