Thread (1 message) 1 message, 1 author, 2012-09-24

Re: [RFC, PATCH] hid-ps3remote: handle multiple keypresses for joypad buttons

From: David Dillow <dave@thedillows.org>
Date: 2012-09-24 13:56:42
Also in: linux-input

On Mon, 2012-09-24 at 13:25 +0200, Antonio Ospite wrote:
In order to make this work I have to put joypad buttons only in one of
the key maps, I don't know if that is compatible with the Harmony
adapter.
I suspect it is, but I'll try to test later tonight. Feel free to merge
my patch and yours and push it upstream under your name/copyright; I'm
not attached to it.
quoted hunk
diff --git a/drivers/hid/hid-ps3remote.c b/drivers/hid/hid-ps3remote.c
index 11a6c1f..fa2e50d 100644
--- a/drivers/hid/hid-ps3remote.c
+++ b/drivers/hid/hid-ps3remote.c
@@ -49,6 +49,26 @@
  * The keymap is generally ordered by the physical location of the buttons,
  * as this makes it easier to verify a correct mapping during testing.
  */
You'd have caught this in cleanup, I'm sure, but the above comment no
longer makes sense.
+static const unsigned int ps3remote_keymap_1[] = {
Probably want a better name -- again, something I'm sure you would have
done during cleanup of this proof-of-concept.
 static const unsigned int ps3remote_keymap[] = {
This map probably should now be ordered per David H. since we're no
longer following the physical layout.

Thanks,
Dave
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help