Re: [PATCH -v2] Bluetooth: Create function to return the ERTM header size
From: Andrei Emeltchenko <hidden>
Date: 2012-05-29 06:58:32
Hi Gustavo, On Mon, May 28, 2012 at 11:58:37PM -0300, Gustavo Padovan wrote:
quoted hunk ↗ jump to hunk
From: Gustavo Padovan <redacted> Simplify the handling of different ERTM header size. We were the same check in some places of the code, and more is expected to come, so just replace them with a function. Signed-off-by: Gustavo Padovan <redacted> --- net/bluetooth/l2cap_core.c | 25 +++++++++++-------------- 1 file changed, 11 insertions(+), 14 deletions(-)diff --git a/net/bluetooth/l2cap_core.c b/net/bluetooth/l2cap_core.c index 6f30d1d..ad06393 100644 --- a/net/bluetooth/l2cap_core.c +++ b/net/bluetooth/l2cap_core.c@@ -814,17 +814,20 @@ static inline void __pack_control(struct l2cap_chan *chan, } } +static inline unsigned int l2cap_ertm_hdr_size(struct l2cap_chan *chan) +{ + if (test_bit(FLAG_EXT_CTRL, &chan->flags)) + return L2CAP_EXT_HDR_SIZE; + else + return L2CAP_ENH_HDR_SIZE; +} + static struct sk_buff *l2cap_create_sframe_pdu(struct l2cap_chan *chan, u32 control) { struct sk_buff *skb; struct l2cap_hdr *lh; - int hlen; - - if (test_bit(FLAG_EXT_CTRL, &chan->flags)) - hlen = L2CAP_EXT_HDR_SIZE; - else - hlen = L2CAP_ENH_HDR_SIZE; + int hlen = l2cap_ertm_hdr_size(chan);
I prefer simpler name like: int hlen = __hdr_size(chan); or __ertm_hdr_size Otherwise looks good. Best regards Andrei Emeltchenko