Thread (2 messages) 2 messages, 2 authors, 2010-09-28

Re: [PATCH] Add checking for agent reply state in adapter

From: Johan Hedberg <hidden>
Date: 2010-09-28 11:18:47

Hi Radek,

On Tue, Sep 28, 2010, Radoslaw Jablonski wrote:
Added checking for agent reply state before cancelling agent in
session_free(..). This check is needed to ensure that memory for
agent request will be freed only once (In that case, free on this
request is called later in the end of agent_reply func)
---
 src/adapter.c |    6 +++++-
 1 files changed, 5 insertions(+), 1 deletions(-)
Thanks. The patch has been pushed upstream with s/is_reply/got_reply/
which is more intuitive imho.

Johan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help