Thread (16 messages) 16 messages, 5 authors, 2025-08-04

Re: [RFC v2 1/4] mm: rename huge_zero_page_shrinker to huge_zero_folio_shrinker

From: David Hildenbrand <hidden>
Date: 2025-08-01 15:30:59
Also in: linux-fsdevel, linux-mm, lkml

On 01.08.25 06:18, Ritesh Harjani (IBM) wrote:
"Pankaj Raghav (Samsung)" [off-list ref] writes:
quoted
From: Pankaj Raghav <redacted>

As we already moved from exposing huge_zero_page to huge_zero_folio,
change the name of the shrinker to reflect that.
Why not change get_huge_zero_page() to get_huge_zero_folio() too, for
consistent naming?
Then we should also rename put_huge_zero_folio(). Renaming 
MMF_HUGE_ZERO_PAGE should probably be done separately.

-- 
Cheers,

David / dhildenb
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help