Re: [PATCH v8 10/10] mm: Renumber FOLL_PIN and FOLL_GET down
From: Christoph Hellwig <hch@infradead.org>
Date: 2023-01-23 18:26:44
Also in:
linux-fsdevel, linux-mm, lkml
From: Christoph Hellwig <hch@infradead.org>
Date: 2023-01-23 18:26:44
Also in:
linux-fsdevel, linux-mm, lkml
On Mon, Jan 23, 2023 at 05:30:07PM +0000, David Howells wrote:
Renumber FOLL_PIN and FOLL_GET down to bit 0 and 1 respectively so that they are coincidentally the same as BIO_PAGE_PINNED and BIO_PAGE_REFFED and also so that they can be stored in the bottom two bits of a page pointer (something I'm looking at for zerocopy socket fragments). (Note that BIO_PAGE_REFFED should probably be got rid of at some point, hence why FOLL_PIN is at 0.) Also renumber down the other FOLL_* flags to close the gaps.
Taking the risk of having a long bikeshed: I much prefer (1U << bitnr) style definition that make it obvious where there are holes, but otherwise: Reviewed-by: Christoph Hellwig <hch@lst.de>