Re: [PATCH 2/5] blk-crypto-fallback: consolidate static variables
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-09-15 07:40:32
Also in:
dm-devel, linux-mmc, linux-scsi
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-09-15 07:40:32
Also in:
dm-devel, linux-mmc, linux-scsi
On Sun, Sep 12, 2021 at 06:31:32PM -0700, Eric Biggers wrote:
From: Eric Biggers <redacted> blk-crypto-fallback.c has many static variables with inconsistent names, e.g. "blk_crypto_*", "crypto_*", and some unprefixed names. This is confusing. Consolidate them all into a struct named "blk_crypto_fallback" so that it's clear what they are.
I always find this pattern of a single instance global struct rather confusing. What is the advantage over just using a consistent prefix?