On Mon, Jul 19, 2021 at 07:40:00PM +0100, Matthew Wilcox (Oracle) wrote:
We still iterate one block at a time, but now we call compound_head()
less often. Rename file_offset to pos to fit the rest of the file.
Signed-off-by: Matthew Wilcox (Oracle) <willy@infradead.org>
Everything in this patch looks ok to me, though I gather there will be
further changes to bio_add_folio, so I'll leave this off for now.
I /am/ beginning to wonder, though -- seeing as Christoph and Matthew
both have very large patchsets changing things in fs/iomap/, how would
you like those landed? Christoph's iterator refactoring looks like it
could be ready to go for 5.15. Matthew's folio series looks like a
mostly straightforward conversion for iomap, except that it has 91
patches as a hard dependency.
Since most of the iomap changes for 5.15 aren't directly related to
folios, I think I prefer iomap-for-next to be based directly off -rcX
like usual, though I don't know where that leaves the iomap folio
conversion. I suppose one could add them to a branch that itself is a
result of the folio and iomap branches, or leave them off for 5.16?
Other ideas?
--D