Re: [PATCH v15 05/17] iomap: Convert iomap_page_release to take a folio
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-07-20 06:55:07
Also in:
linux-fsdevel, linux-mm
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-07-20 06:55:07
Also in:
linux-fsdevel, linux-mm
On Mon, Jul 19, 2021 at 07:39:49PM +0100, Matthew Wilcox (Oracle) wrote:
-static void
-iomap_page_release(struct page *page)
+static void iomap_page_release(struct folio *folio)
{
- struct iomap_page *iop = detach_page_private(page);
- unsigned int nr_blocks = i_blocks_per_page(page->mapping->host, page);
+ struct iomap_page *iop = folio_detach_private(folio);
+ unsigned int nr_blocks = i_blocks_per_folio(folio->mapping->host,
+ folio);Nit: but I find this variant much easier to read: unsigned int nr_blocks = i_blocks_per_folio(folio->mapping->host, folio); Otherwise looks good: Reviewed-by: Christoph Hellwig <hch@lst.de>