Re: [PATCH v3 2/5] nvme-core: introduce complete failed request
From: Christoph Hellwig <hch@lst.de>
Date: 2021-01-21 08:44:11
Also in:
linux-nvme
From: Christoph Hellwig <hch@lst.de>
Date: 2021-01-21 08:44:11
Also in:
linux-nvme
+static inline void nvme_complete_failed_req(struct request *req)
I think the name is too generic, and the function also needs a little comment, especially as it forces a specific error code.
+{
+ nvme_req(req)->status = NVME_SC_HOST_PATH_ERROR;
+ blk_mq_set_request_complete(req);
+ nvme_complete_rq(req);
+}Also no need to mark this as an inline function.