Thread (123 messages) 123 messages, 6 authors, 2020-08-18

Re: [PATCH RFC v7 02/12] blk-mq: rename blk_mq_update_tag_set_depth()

From: Hannes Reinecke <hare@suse.de>
Date: 2020-06-23 14:23:37
Also in: linux-scsi

On 6/23/20 1:25 PM, John Garry wrote:
On 11/06/2020 09:26, John Garry wrote:
quoted
On 11/06/2020 03:57, Ming Lei wrote:
quoted
On Thu, Jun 11, 2020 at 01:29:09AM +0800, John Garry wrote:
quoted
From: Hannes Reinecke <hare@suse.de>

The function does not set the depth, but rather transitions from
shared to non-shared queues and vice versa.
So rename it to blk_mq_update_tag_set_shared() to better reflect
its purpose.
It is fine to rename it for me, however:

This patch claims to rename blk_mq_update_tag_set_shared(), but also
change blk_mq_init_bitmap_tags's signature.
I was going to update the commit message here, but forgot again...
quoted
So suggest to split this patch into two or add comment log on changing
blk_mq_init_bitmap_tags().
I think I'll just split into 2x commits.
Hi Hannes,

Do you have any issue with splitting the undocumented changes into 
another patch as so:
No, that's perfectly fine.

Kashyap, I've also attached an updated patch for the elevator_count 
patch; if you agree John can include it in the next version.

Cheers,

Hannes
-- 
Dr. Hannes Reinecke            Teamlead Storage & Networking
hare@suse.de                               +49 911 74053 688
SUSE Software Solutions GmbH, Maxfeldstr. 5, 90409 Nürnberg
HRB 36809 (AG Nürnberg), Geschäftsführer: Felix Imendörffer

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help