Re: [PATCH 4/8] nvme: implement mq_ops->commit_rqs() hook
From: Jens Axboe <axboe@kernel.dk>
Date: 2018-11-28 13:07:34
Also in:
linux-nvme
From: Jens Axboe <axboe@kernel.dk>
Date: 2018-11-28 13:07:34
Also in:
linux-nvme
On 11/28/18 12:20 AM, Christoph Hellwig wrote:
quoted
+static inline int nvme_next_ring_index(struct nvme_queue *nvmeq, u16 index) +{ + if (++index == nvmeq->q_depth) + return 0; + + return index;Can you please just drop this helper? It makes the code not only less readable but also longer. Otherwise the change looks fine to me.
Alright, dropped the helper. -- Jens Axboe