Re: [PATCH 4/8] nvme: implement mq_ops->commit_rqs() hook
From: Christoph Hellwig <hch@infradead.org>
Date: 2018-11-28 07:20:39
Also in:
linux-nvme
From: Christoph Hellwig <hch@infradead.org>
Date: 2018-11-28 07:20:39
Also in:
linux-nvme
+static inline int nvme_next_ring_index(struct nvme_queue *nvmeq, u16 index)
+{
+ if (++index == nvmeq->q_depth)
+ return 0;
+
+ return index;Can you please just drop this helper? It makes the code not only less readable but also longer. Otherwise the change looks fine to me.