Re: [PATCH 14/16] bcache: Make csum_set() implementation easier to read From: Christoph Hellwig <hch@lst.de> Date: 2018-03-15 15:57:51 On Thu, Mar 15, 2018 at 08:08:12AM -0700, Bart Van Assche wrote:+#define csum_set(i) ({ \ + const void *p = (void *)(i) + sizeof(uint64_t); \ + const void *q = bset_bkey_last(i); \ + \ + bch_crc64(p, q - p); \ +}) Having this as a macro is really ugly. Any chane to turn this into a proper function?
Keyboard shortcuts hback out one level jnext message in thread kprevious message in thread ldrill in Escclose help / fold thread tree ?toggle this help