Re: [PATCH 8/9] nvme: track shared namespaces
From: Christoph Hellwig <hch@lst.de>
Date: 2017-09-24 15:25:31
Also in:
linux-nvme
From: Christoph Hellwig <hch@lst.de>
Date: 2017-09-24 15:25:31
Also in:
linux-nvme
On Thu, Sep 21, 2017 at 11:16:31AM -0400, Keith Busch wrote:
If there weren't resistence to renaming structs, it would be more aligned to how the specification calls these if we rename nvme_ns to nvme_ns_path, and what you're calling nvme_ns_head is should just be the nvme_ns.
Then we'd still need a good name for what's now nvme_ns :) But seriously speaking - I'm a little worried because Linus is really pissed at me for doing major refactoring in block land (by proxy of Jens who gets all the heat). I just don't feel comfortable with a rename at the moment, even if it's the right thing.