On Thu, Sep 14, 2017 at 05:04:13PM -0700, Omar Sandoval wrote:
On Sat, Sep 02, 2017 at 11:17:18PM +0800, Ming Lei wrote:
quoted
This function is introduced for dequeuing request
from sw queue so that we can dispatch it in
scheduler's way.
More importantly, some SCSI devices may set
q->queue_depth, which is a per-request_queue limit,
and applied on pending I/O from all hctxs. This
function is introduced for avoiding to dequeue too
many requests from sw queue when ->dispatch isn't
flushed completely.
blk_mq_dispatch_rq_from_ctx() doesn't actually dispatch the request. Can
you please rename it blk_mq_dequeue_from_ctx() or something like that?
(Same for the dispatch_rq_from_ctx helper.)
It makes sense, will do that.
--
Ming