Re: [PATCH V4 04/14] blk-mq-sched: move actual dispatching into one helper
From: Omar Sandoval <osandov@osandov.com>
Date: 2017-09-19 19:21:50
On Sat, Sep 02, 2017 at 11:17:19PM +0800, Ming Lei wrote:
quoted hunk ↗ jump to hunk
So that it becomes easy to support to dispatch from sw queue in the following patch. No functional change. Reviewed-by: Bart Van Assche <redacted> Signed-off-by: Ming Lei <redacted> --- block/blk-mq-sched.c | 28 ++++++++++++++++++---------- 1 file changed, 18 insertions(+), 10 deletions(-)diff --git a/block/blk-mq-sched.c b/block/blk-mq-sched.c index 845e5baf8af1..f69752961a34 100644 --- a/block/blk-mq-sched.c +++ b/block/blk-mq-sched.c@@ -89,6 +89,22 @@ static bool blk_mq_sched_restart_hctx(struct blk_mq_hw_ctx *hctx) return false; } +static void blk_mq_do_dispatch(struct request_queue *q, + struct elevator_queue *e, + struct blk_mq_hw_ctx *hctx)
You rename this to blk_mq_do_dispatch_sched() in the next patch, might as well name it that way in the first place. Besides that, Reviewed-by: Omar Sandoval <redacted>
quoted hunk ↗ jump to hunk
+{ + LIST_HEAD(rq_list); + + do { + struct request *rq; + + rq = e->type->ops.mq.dispatch_request(hctx); + if (!rq) + break; + list_add(&rq->queuelist, &rq_list); + } while (blk_mq_dispatch_rq_list(q, &rq_list)); +} + void blk_mq_sched_dispatch_requests(struct blk_mq_hw_ctx *hctx) { struct request_queue *q = hctx->queue;@@ -136,16 +152,8 @@ void blk_mq_sched_dispatch_requests(struct blk_mq_hw_ctx *hctx) * on the dispatch list, OR if we did have work but weren't able * to make progress. */ - if (do_sched_dispatch && has_sched_dispatch) { - do { - struct request *rq; - - rq = e->type->ops.mq.dispatch_request(hctx); - if (!rq) - break; - list_add(&rq->queuelist, &rq_list); - } while (blk_mq_dispatch_rq_list(q, &rq_list)); - } + if (do_sched_dispatch && has_sched_dispatch) + blk_mq_do_dispatch(q, e, hctx); } bool blk_mq_sched_try_merge(struct request_queue *q, struct bio *bio,-- 2.9.5