On 09/21/2017 09:29 AM, Christoph Hellwig wrote:
So the check change here looks good to me.
I don't like like the duplicate code, can you look into sharing
the new segment checks between the two functions and the existing
instance in ll_merge_requests_fn by passing say two struct bio *bio1
and struct bio *bio2 pointer instead of using req->bio and req->biotail?
Also please include the information that you posted in the reply to
the other patch in the description for this one.
I have just sent a new version which contains more comment before I see
this mail. I will send out another new version that apply your advice later.
Thanks for your kind and fair comment.
Jianchao