Re: [PATCH] block: consider merge of segments when merge bio into rq
From: Christoph Hellwig <hch@infradead.org>
Date: 2017-09-21 01:29:53
Also in:
lkml
From: Christoph Hellwig <hch@infradead.org>
Date: 2017-09-21 01:29:53
Also in:
lkml
So the check change here looks good to me. I don't like like the duplicate code, can you look into sharing the new segment checks between the two functions and the existing instance in ll_merge_requests_fn by passing say two struct bio *bio1 and struct bio *bio2 pointer instead of using req->bio and req->biotail? Also please include the information that you posted in the reply to the other patch in the description for this one.