Re: [PATCH v2 12/12] block: Rename blk_mq_rq_{to,from}_pdu()
From: Christoph Hellwig <hch@lst.de>
Date: 2017-06-01 06:08:04
From: Christoph Hellwig <hch@lst.de>
Date: 2017-06-01 06:08:04
On Wed, May 31, 2017 at 03:52:46PM -0700, Bart Van Assche wrote:
Commit 6d247d7f71d1 ("block: allow specifying size for extra command
data") added support for .cmd_size to blk-sq. Due to that patch the
blk_mq_rq_{to,from}_pdu() functions are also useful for single-queue
block drivers. Hence remove "_mq" from the name of these functions.
This patch does not change any functionality. Most of this patch has
been generated by running the following shell command:I don't really see the point of this as it's primarily a blk-mq API and we still hope to get rid of the old code. But I'm not necessarily against it either.