Thread (18 messages) 18 messages, 3 authors, 2017-05-16

Re: Playing with BFQ

From: Paolo Valente <hidden>
Date: 2017-05-03 09:24:03

Il giorno 03 mag 2017, alle ore 11:16, Markus Trippelsdorf =
[off-list ref] ha scritto:
=20
On 2017.05.03 at 10:00 +0200, Sedat Dilek wrote:
quoted
On Tue, May 2, 2017 at 2:16 PM, Markus Trippelsdorf
[off-list ref] wrote:
quoted
On 2017.05.02 at 14:07 +0200, Sedat Dilek wrote:
quoted
On Tue, May 2, 2017 at 10:00 AM, Markus Trippelsdorf
[off-list ref] wrote:
quoted
On 2017.05.02 at 09:54 +0200, Sedat Dilek wrote:
quoted
Hi,
=20
I want to play with BFQ.
=20
My base is block-next as of 28-Apr-2017.
[...]
quoted
quoted
Not sure if the attached patches make sense (right now).
=20
No, it doesn't make sense at all.
=20
Hmm, I looked at 4.11.0-v8r11 and 0001 has exactly what my 2 =
patches do :-).
quoted
quoted
=20
BFQ started as a conventional scheduler. But because mq is the way =
of
quoted
quoted
the future it was ported before it was accepted into mainline.
=20
=20
I am still playing and want to do my own experiences with BFQ.
=20
Not sure if FIO is a good testcase-tool here.
=20
So if MQ is the way why isn't the Kconfig called =
CONFIG_MQ_IOSCHED_BFQ
quoted
according to CONFIG_MQ_IOSCHED_DEADLINE?
=20
Good point. The current naming is confusing.
=20
Also:
# cat /sys/block/sda/queue/scheduler
mq-deadline [kyber] bfq none
=20
These should all be prefixed with mq-.
=20
The logic here, as proposed by Jens, is not to add the mq tag when
there is no risk of ambiguity (such as between deadline and
mq-deadline). I'm open to any sensible choice.

Thanks,
Paolo
--=20
Markus
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help