Thread (18 messages) 18 messages, 3 authors, 2017-05-16

Re: Playing with BFQ

From: Sedat Dilek <hidden>
Date: 2017-05-13 07:54:54

On Wed, May 3, 2017 at 11:24 AM, Paolo Valente [off-list ref] wrote:
quoted
Il giorno 03 mag 2017, alle ore 11:16, Markus Trippelsdorf [off-list ref] ha scritto:

On 2017.05.03 at 10:00 +0200, Sedat Dilek wrote:
quoted
On Tue, May 2, 2017 at 2:16 PM, Markus Trippelsdorf
[off-list ref] wrote:
quoted
On 2017.05.02 at 14:07 +0200, Sedat Dilek wrote:
quoted
On Tue, May 2, 2017 at 10:00 AM, Markus Trippelsdorf
[off-list ref] wrote:
quoted
On 2017.05.02 at 09:54 +0200, Sedat Dilek wrote:
quoted
Hi,

I want to play with BFQ.

My base is block-next as of 28-Apr-2017.
[...]
quoted
quoted
Not sure if the attached patches make sense (right now).
No, it doesn't make sense at all.
Hmm, I looked at 4.11.0-v8r11 and 0001 has exactly what my 2 patches do :-).
BFQ started as a conventional scheduler. But because mq is the way of
the future it was ported before it was accepted into mainline.
I am still playing and want to do my own experiences with BFQ.

Not sure if FIO is a good testcase-tool here.

So if MQ is the way why isn't the Kconfig called CONFIG_MQ_IOSCHED_BFQ
according to CONFIG_MQ_IOSCHED_DEADLINE?
Good point. The current naming is confusing.

Also:
# cat /sys/block/sda/queue/scheduler
mq-deadline [kyber] bfq none

These should all be prefixed with mq-.
The logic here, as proposed by Jens, is not to add the mq tag when
there is no risk of ambiguity (such as between deadline and
mq-deadline). I'm open to any sensible choice.
The naming is confusing but I can understand the point of Jens.

The Kconfigs of BFQ in block/Kconfig.iosched need a move (see my two
patches attached in the initial posting).
AFAICS you have the same in your latest BFQ-patchset for Linux v4.11.y.

I am re-attaching my two patches.

- Sedat -

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help