Thread (7 messages) 7 messages, 3 authors, 2026-03-12

Re: [PATCH 1/2] dt-bindings: PCI: fsl,imx6q-pcie: Switch to undeprecated reset-gpios

From: Krzysztof Kozlowski <hidden>
Date: 2026-03-12 18:43:36
Also in: imx, linux-devicetree, linux-pci, lkml

On 12/03/2026 17:29, Krzysztof Kozlowski wrote:
On 12/03/2026 10:18, Sherry Sun wrote:
quoted
quoted
Subject: [PATCH 1/2] dt-bindings: PCI: fsl,imx6q-pcie: Switch to undeprecated
reset-gpios

GPIOs with "gpio" suffix were long time ago deprecated, thus "reset-gpios" should
be used.  Linux kernel supports both, referenced schema snps,dw-pcie-
common.yaml lists both as well and this schema uses
unevaluatedProperties:false, thus change has no impact except code readability
and removing deprecated patterns.

Signed-off-by: Krzysztof Kozlowski <redacted>
---
 Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml | 5 -----
 1 file changed, 5 deletions(-)
diff --git a/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
b/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
index 12a01f7a5744..b9ba938c6239 100644
--- a/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
+++ b/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
@@ -58,11 +58,6 @@ properties:
       - const: msi
       - const: dma

-  reset-gpio:
-    description: Should specify the GPIO for controlling the PCI bus device
-      reset signal. It's not polarity aware and defaults to active-low reset
-      sequence (L=reset state, H=operation state) (optional required).
-
Add Dmitry and Bartosz.

Hi Krzysztof,
Seems this property is still handled in gpiolib-of.c, see commit b8b80348c57b
("gpiolib: of: add polarity quirk for Freescale PCIe controller").
Maybe need to change the quirk gpio_propname here too.
Oh, I missed that completely. Thanks for mentioning it.

1. Having this property in drivers/gpio/gpiolib-of.c means we should
keep it in the schema as deprecated, because each ABI should be documented.

2. I can drop reset-gpio-active-high from DTS as well, because
reset-gpios have proper flag.

3. We don't need to update gpiolib-of.c, because standard flag from
reset-gpios will be used.
quoted
quoted
   reset-gpio-active-high:
     description: If present then the reset sequence using the GPIO
       specified in the "reset-gpio" property is reversed (H=reset state,
 Also change the "reset-gpio" to "reset-gpios" in this description.
Also here - no need to update, because this will be used only for
reset-gpio.
I will send a v2.

Best regards,
Krzysztof
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help