Thread (7 messages) 7 messages, 3 authors, 2026-03-12

RE: [PATCH 1/2] dt-bindings: PCI: fsl,imx6q-pcie: Switch to undeprecated reset-gpios

From: Hongxing Zhu <hongxing.zhu@nxp.com>
Date: 2026-03-12 06:06:00
Also in: imx, linux-devicetree, linux-pci, lkml

-----Original Message-----
From: Krzysztof Kozlowski <redacted>
Sent: 2026年3月11日 23:50
To: Hongxing Zhu <hongxing.zhu@nxp.com>; Lucas Stach
[off-list ref]; Lorenzo Pieralisi [off-list ref]; Krzysztof
Wilczy��ski [off-list ref]; Manivannan Sadhasivam
[off-list ref]; Rob Herring [off-list ref]; Bjorn Helgaas
[off-list ref]; Krzysztof Kozlowski [off-list ref]; Conor
Dooley [off-list ref]; Frank Li [off-list ref]; Sascha Hauer
[off-list ref]; Pengutronix Kernel Team
[off-list ref]; Fabio Estevam [off-list ref]; Jingoo Han
[off-list ref]; Gustavo Pimentel
[off-list ref]; linux-pci@vger.kernel.org;
linux-arm-kernel@lists.infradead.org; imx@lists.linux.dev;
devicetree@vger.kernel.org; linux-kernel@vger.kernel.org
Cc: Krzysztof Kozlowski <redacted>
Subject: [PATCH 1/2] dt-bindings: PCI: fsl,imx6q-pcie: Switch to undeprecated
reset-gpios

GPIOs with "gpio" suffix were long time ago deprecated, thus "reset-gpios"
should be used.  Linux kernel supports both, referenced schema
snps,dw-pcie-common.yaml lists both as well and this schema uses
unevaluatedProperties:false, thus change has no impact except code
readability and removing deprecated patterns.

Signed-off-by: Krzysztof Kozlowski <redacted>
Acked-by: Richard Zhu <hongxing.zhu@nxp.com>
Thanks.

Best Regards
Richard Zhu
quoted hunk ↗ jump to hunk
---
 Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml | 5 -----
 1 file changed, 5 deletions(-)
diff --git a/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
b/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
index 12a01f7a5744..b9ba938c6239 100644
--- a/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
+++ b/Documentation/devicetree/bindings/pci/fsl,imx6q-pcie.yaml
@@ -58,11 +58,6 @@ properties:
       - const: msi
       - const: dma

-  reset-gpio:
-    description: Should specify the GPIO for controlling the PCI bus device
-      reset signal. It's not polarity aware and defaults to active-low reset
-      sequence (L=reset state, H=operation state) (optional required).
-
   reset-gpio-active-high:
     description: If present then the reset sequence using the GPIO
       specified in the "reset-gpio" property is reversed (H=reset state,
--
2.51.0
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help