Thread (7 messages) 7 messages, 4 authors, 2026-03-02

Re: [RFC PATCH 2/2] arm64: dts: imx8mp-frdm: Use symbolic macros for IOMUXC_SW_PAD_CTL_PAD

From: Daniel Baluta <hidden>
Date: 2026-03-02 10:27:15
Also in: imx, linux-devicetree, lkml

On 2/27/26 17:09, Frank Li wrote:
On Fri, Feb 27, 2026 at 03:02:42PM +0200, Daniel Baluta wrote:
quoted
Currently, in order to configure IOMUXC_SW_PAD_CTL_PAD a magic raw value
is written in this register. This makes code not obvious to read and
modify.

So, to help with code readability instead of the magic values use
symbolic macros.
Use symbolic macros instead of the magic values to improve code readability.

Will fix in v2. 

[..]
+#define MX8MP_NAND_DATA_DEFAULT (MX8MP_FSEL_FAST | MX8MP_PULL_UP | \
+				 MX8MP_HYS_SCHMITT | MX8MP_PULL_ENABLE)

It is not NAND, should be
	MX8MP_USDHC_DATA_DEFAULT
True. Will fix in v2. 

Thanks Frank and Maud.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help